Add arguments to configure script.

parent eacfacd5
......@@ -7,7 +7,7 @@ ENV OTP_VERSION="18.3"
RUN set -xe \
&& OTP_DOWNLOAD_URL="https://github.com/erlang/otp/archive/OTP-$OTP_VERSION.tar.gz" \
&& OTP_DOWNLOAD_SHA256="8d5436faf37a1273c1b8529c4f02c28af0eccde31e52d474cb740b012d5da7e6" \
&& buildDeps='unixodbc-dev' \
&& buildDeps='unixodbc-dev libssl-dev' \
&& apt-get update \
&& apt-get install -y --no-install-recommends $buildDeps \
&& curl -fSL -o otp-src.tar.gz "$OTP_DOWNLOAD_URL" \
......@@ -17,7 +17,7 @@ RUN set -xe \
&& rm otp-src.tar.gz \
&& cd /usr/src/otp-src \
&& ./otp_build autoconf \
&& ./configure --enable-dirty-schedulers \
&& ./configure --enable-dirty-schedulers --enable-threads --enable-dynamic-ssl-lib --enable-smp-support --enable-shared-zlib --with-hipe --enable-kernel-poll \
&& make -j$(nproc) \
&& make install \
&& find /usr/local -name examples |xargs rm -rf \
......
......@@ -6,7 +6,7 @@ ENV OTP_VERSION="19.0-rc0@e038cbe"
# build process:
RUN set -xe \
&& OTP_DOWNLOAD_SHA1=a29ac533c61da305eb8f3e96118b40e20a524cd7 \
&& buildDeps='unixodbc-dev' \
&& buildDeps='unixodbc-dev libssl-dev' \
&& apt-get update \
&& apt-get install -y --no-install-recommends $buildDeps \
&& mkdir -p /usr/src/otp-src \
......@@ -16,7 +16,7 @@ RUN set -xe \
&& rm otp-src.tar.gz \
&& cd /usr/src/otp-src \
&& ./otp_build autoconf \
&& ./configure \
&& ./configure --enable-dirty-schedulers --enable-threads --enable-dynamic-ssl-lib --enable-smp-support --enable-shared-zlib --with-hipe --enable-kernel-poll \
&& make -j$(nproc) \
&& make install \
&& find /usr/local -name examples |xargs rm -rf \
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment